Nissan Versa Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone, I have a 2007 Nissan Versa on which the aux input has been working fine for years. But recently the radio started to display the message “No Aux” when the aux button is pressed and the input no longer works (by not working I mean…I hook up my iPhone to aux and no audio comes out of the car’s speakers, not even any buzz or static when plugging in the 3.5mm aux cable to my phone).

When it started
This all started when my friend was connecting a ground loop isolator for me to get rid of the annoying buzzing sound I get when I have my iPhone 4S connected to the aux input and charging off a USB car charger. In the past I would get around this by using an inverter and a 120v USB wall charger. It was a really clunky solution.

What I've tried
I tried turning on and off the radio several times, pressing the aux button repeatedly, pressing the “source” button on the steering wheel, unplugging/re-plugging the aux cable, trying a different aux cable, etc.

I’ve Googled a lot but cannot find anything! Any help is greatly appreciated!!
 

·
Registered
Joined
·
143 Posts
My guess is the radio firmware is having a problem. Not sure how you reload it on your radio. Personally, you could buy a new radio with many more features from crutchfield.com on black Friday and replace it. That's what I'd do.
 

·
Registered
Joined
·
84 Posts
Have you tried to use another device to see if it works? The input stage of the AUX port could possibly be damaged from the ground loop (I know where those low impedance circuits with current can do some damage).
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top