Nissan Versa Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
I have the same or similar issue with my 2018 versa. Started with clogged cats( yes cats). There is an exhaust manifold cat and a cat after that.
Never got a cat code so never knew it was the problem until I couldn't go over 50mph.
Punched out both cats and car ran great for 2 months. Misfire came back and mph went down. Changed upstream 02 and mpg is back except for when the car is under a load or accelerating. Started toying with down stream 02 with fouler's and is getting worse. Going to the store to get new down stream 02 and test with and without fouler.
OBD2 says it's rich which I believe is coming from down stream 02 leaning it out.
Stft is running 0 to -?? . I think the random misfire is a fuel issue. It does not feel like a spark or coil issue. Misfire only occurs (flashing check engine light) at idle and stops flashing when driving.
It would be great to fix this POS because I am getting 35mpg + and 45mpg at 62mph drafting and vehicle.
 

·
Registered
Joined
·
8 Posts
Worked on the car again this am. Stft is +/- 3 and left is 8.5 at idle and 7.5 at 2500rpm.
Replaced coil pack #3 (p0303).

Upstream 02 at 0.7 volts moving up and down and down stream 02 at .2 at idle and .35 at 2500 rpm.

Got some new codes too. Air/fuel balance along with maf low voltage.

Replaced with new maf and still the same faults after replacing and clearing codes.

Not sure I can keep going with the car like this. Don't think iam gonna get it fixed beforing selling it.
 

·
Registered
Joined
·
8 Posts
Took the car for a spin and rechecked fuel trims and 02 readings.
Idle:
Stft 6/8 ltft 9.38
Upstream 02 at 2.18 and down 02 at .275

2500rpm:
Stft 1.57 ltft 1.57
Upstream 02 at 2.17 and down at .295
 

·
Registered
Joined
·
8 Posts
P0303 cylinder 3 misfire
P0300 multi misfire
P0102 MAF
Cylinder 3 900 misfires in 3 minutes at idle.
Cylinder 4 76 misfires in 3 minutes at idle.
Bank 1 02 sensor lambda oscillating .995/1.000

Coil packs, spark plugs, and MAF replaced the other day.

Starting to have a feeling that even though the mechanic said he punched out the exhaust manifold catalytic, it's acting strangly like it was gutted too good.
Put some dura lube extreme catalytic converter cleaner in there and engine and exhaust sounds different.

Over the weekend I also checked for vaccume leaks with propane. Nope. Couldn't find any leaks.
 

·
Registered
Joined
·
8 Posts
Great ideas. Will work on this weekend and report back.
I'll try to lean it out and watch lambda numbers. If it leans out, I'll drop the exhaust and see if the guy really did gut the cat or just drilled holes in it.

Bank 2 02 doesn't ocillate because I used a spark plug fouler to pull it out of the exhaust stream.

And, it is running rich.

Another thing is the engine falls on its face when shifting and there's a pause to rev it up.feels like a long pause to me.
Everything is pointing to a clogged up exhaust.

Anywho,
Thank you and the forums help. Iam a first time poster and hope it helps someone else.
 

·
Registered
Joined
·
8 Posts
Well,
The cat is definitely hogged.

Forced lean with brake booster line.lambda went to 1.3 and car stalled immediately. Then, just made a very small leak and was able to watch lambda run 1 to 1.15 without stalling out.Upstream 02 responded correctly and followed lambda.

Ran propane again across engine bay and seen no changes. Opened air filter and flowed propane in there. Both lambda and upstream 02 responded correctly.

Don't have a compression tester and iam sick and tired of removing the entire intake manifold to get to the coil packs and spark plugs.
Looks like there are 2 injectors per cylinder (wtf). That's the only thing I never changed.
Injectors were reading something like 2millisecond at idle. Unfortunately I can't read them independently.

Any other crazy ideas before I take it in for you injectors or sell it?

Again,
Thank you and the Nissan versa forum for letting me post and helping me out.
 

·
Registered
Joined
·
8 Posts
One more clue. When the car falls on its face when shifting and there's that 1 second pause to rev up from idle,
If I turn the car off and then back on, it runs perfectly fine for 3 to 5 minutes and then goes back to a turd.
 
1 - 8 of 8 Posts
Top