Nissan Versa Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello
I have the mini blue (OBDII), it doesn’t work on Nissan TIIDA / VERSA 2008. The error is attached below.
……….
ECU problem
The ECU is reporting that it does not support the reading of any PIDs.
Your vehicle may not be OBD2 compliant OR the vehicle ECU has not been enabled by your dealer/manufacturer for OBD2 access
Torque will probably not be able to retrieve information due to this problem
……….
Note: the same OBDII work on a lot of other cars accept Nissan TIIDA/versa 2008
The link of the OBDII is:
https://www.aliexpress.com/item/ELM327-v1-5-Mini-apply-...
Any help about this problem?
Thanks
 

·
Registered
Joined
·
1,028 Posts
Likely your device rather than the car, the OBD MUST be enabled to set the car up from the factory. And those crap cheap devices are faulty so much it's not funny. They use cheap crap chips that are often not fully Elm enabled and them saying so means nothing. The Elm chip alone costs $40 for just the chip by itself and if the device not priced higher than that, it is NOT an Elm, just a crap clone.

I have taken several apart that didn't work to find wires broken in them right from the factory.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
If you know an original Bluetooth OBDII send me its link.

Its important for me to use my android torque software.
 

·
Registered
Joined
·
1,028 Posts
You won't be able to afford it, the better ones do not use that app, it is considered crap like the cheap clone chips are. A full true Elm device can easily run $150 and that is the floor, the better ones can run $300+.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well I am not a mechanic to buy the 300+ $ one, the clone OBDII is working well for me on all kind of cars accept VERSA.

The only idea about torque is to see the temperature of engine water.

If the OBDII is not Bluetooth then I am not interested in it.
 

·
Registered
Joined
·
1,028 Posts
If you are using an older elm you may not have one that reads CANBUS, which is the language used after like '03-'05 on many models of car.
 
1 - 6 of 6 Posts
Top