Nissan Versa Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So, bought a 2008 only to find out it was rebuilt after the fact. Mostly good after additional $1200 but the radio light comes back on 5 seconds after the key is removed. Getting tired of having to pull the fuse to save the battery.

The radio itself does not come on, just the clock light. Any idea on where to start? I have removed the radio already and checked the harness... looks original and guessing a short in the radio itself?
 

·
Registered
Joined
·
1,209 Posts
well from my understanding, there is a constant 12v wire that keeps the clock going when you turn the car off, but the radio only comes on if the 12v accessory wire has the power running through it, which is activated through the use of turning the key. When the key is turned, it sends the signal to the radio for it to turn on. So I assume there maybe something wrong with the radio, ignition switch, or maybe the accessory wire is short. Thats about all I can tell you. One thing I do know, there is no ground wire from the radio. Its the illumination wire (orange), dimmer wire (black/silver dots), 12v constant wire (brownish-orange), and 12v accessory wire (cyan, or light green). They are all together.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
AltaVersa
Nissan Versa Forums
We’re a forum community dedicated to Nissan Versa owners & enthusiasts. Come join the discussion on performance, troubleshooting, accessories, purchasing, maintenance and more!
Full Forum Listing
Top