Nissan Versa Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
2,364 Posts
Discussion Starter #1 (Edited)
Hello Everyone! Hope everything is going well. I haven't had any problems with the Versa. Just regular maintenance

Anyway, lets get to it :thumb2:

I noticed my front speakers are louder than the rear.
I checked each speaker thru the radio settings and just the Rear Right speaker has no sound.

I stilll have the Factory Radio and Factory Speakers
All 4 speakers worked when I got the car,
not sure when left rear quit working

How hard is it to remove the rear door pannel?
it has electric windows
it might have a short wire, it may not, any help on how to fix that speaker would be great!!
 

·
Premium Member
Joined
·
4,524 Posts
I have crank windows so its a little different but not hard at all. Just have to remove the switch panels, unplug the switches, remove the bolt off of the arm rest, then remove the clips that hold the door panel in place. Now, as far as removing the speaker itself, its just 3 bolts and you're good.
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #3
I have crank windows so its a little different but not hard at all. Just have to remove the switch panels, unplug the switches, remove the bolt off of the arm rest, then remove the clips that hold the door panel in place. Now, as far as removing the speaker itself, its just 3 bolts and you're good.
Thanks man :thumb2:
so the only tool I need is a screw driver.

I hope I get this speaker working this memorial weekend.
the only person that affects the problem is the person sitting by the door.
I would also like to add a tweeter on each door, eveeeeentually
 

·
Premium Member
Joined
·
4,524 Posts
Good idea. I saw something similar on google, and I thought about doing it too but Im not a big fan of drilling my interior. I installed mine on the A-pillar. Keep us updated.
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #9
I have crank windows so its a little different but not hard at all. Just have to remove the switch panels, unplug the switches, remove the bolt off of the arm rest, then remove the clips that hold the door panel in place. Now, as far as removing the speaker itself, its just 3 bolts and you're good.
I see there's a piece on top of the door panel, I'm trying to remove that first but I don't want to break it.

does the rest of the panel just hooks to the door? I don't think I saw any screws
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #11
this piece right here


and then I see this round white clips that hook to the panel




I didn't see a screw on the arm rest, let me check again
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #12 (Edited)
okay I was able to put that top piece back on, I think I broke the little clips but it didn't hurt anything


now the door is back to how it was, but I didn't see any screws


and its the Left side, not the Right side
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #15
KooL Thanks!!!

but will continue this tomorrow, something came up.

I don't know why I was thinking I had to remove that top piece... :shrug:
¯\_(ツ)_/¯

so step by step is like this:

1. remove switch cover with flat headed screw drive
2. remove screw inside the cubby
3. remove switch wire
4. remove door panel
 

·
Premium Member
Joined
·
4,524 Posts
Yessir, again, mine is a little different because I dont have power windows but its very similar...

Remove screw...



Remove wiring/buttons panel...



Pull tabs...



Push upward...



This is how I removed my door panel. Be careful...and patient. :thumbsup:
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #17
thanks man!!

I like the black and white HD pics!!!

I need a HD camera lol


may next post should have the pics with the panel off, then I will see what's going on with the speaker.
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #19 (Edited)
No problem. Let know how it goes.
Good news! I got sound back!!!! :thumb2:

I just got done putting it back together and uploaded the pics

I did what you said so step by step pics here we go!
:eatpopcorn:
















then it came off pulling it lil by lil


there's the speaker, I turned the radio on and it had no sound




took the speaker off to test it inside my house


its a 20Watt speaker :ihih:


went inside my house and the speaker worked fine...
so my next step was to test the connector clip bc it had no sound.
so I just went inside and got a speaker and hooked the negative and positive to the connector clip and again...no sound :nonod:




so I was wondering if the clip had a short in it or maybe the positive and negative ports were too small or blocked or something
took a small knife to clean the ports and make sure they had a better connection



then I plugged the speaker back on and Bingo!! music started playing


I opened and closed the door 3 times to check the connection and the speaker was still playing.

Now all 4 speakers are working fine :thumb2:

Thanks A LOT for the help!!! :cheers2:

Case Closed!
 

·
Registered
Joined
·
2,364 Posts
Discussion Starter #20
here's playing
I don't like country much..this was just a test

my next step would be detail the inside and later on go online and order a couple tweeters
 
1 - 20 of 23 Posts
Top