Nissan Versa Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have a 2016 Nissan Versa SV 1.6 L with automatic transmission and 56K miles.I removed the throttle body(first time) to do a cleaning because it was the last thing suggested for the issue I was having. The initial problem was that my mpg decreased by 10mpg and the idle was high and not steady. I had already had an injection service done. After removing the throttle body, I cleaned it with a microfiber rag and CRC throttle body & air intake cleaner moving the butterfly and working all the residue off. I put the part back on and made sure to reconnect all the cables and hoses. The car starts fine but sounds rough, the idle is steady at 1K RPM, and the exhaust sounds like a lawn mower. I immediately saw the CEL. I followed the instructions here to relearn the idle: http://www.nissanversaforums.com/#/topics/21530
I did it a few times because I wasn't sure if I did the procedure correctly or if it was the correct procedure in the first place. I still had the issue, so I got the code checker out. These are the codes I'm receiving:
P0300 RANDOM/MULTIPLE CYLINDER MISFIRE
P0304 CYLINDER 4 MISFIRE
P219A Bank 1 Air-Fuel Ratio Imbalance
P219F Cylinder 4 Air-Fuel Ratio Imbalance

Does anyone know what I may have done wrong? What is it I need to check to clear these codes? What else do I need to do to fix this?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Never mind, I was dumb and missed plugging in the ignition coil. At least that's what I was told. Engine is running great now.
 
1 - 2 of 2 Posts
Top