Nissan Versa Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hey guys, my SES light came on about a 1/4 mile after I filled up the tank. (Im at 53k miles)

Went and pulled the code P0171 - Fuel Injection System Too Lean Bank 1

-low fuel pressure
-Blocked injectors
-large vacuum leak
-MAF sensor fault

I couldn't find any vac leaks, the MAF is very clean, and I used injector cleaner 3 tanks ago. Re-did all the connections on the intake, and checked the exhaust for leaks.

The only symptom I get is a consistent high idle ~1000rpm, no loss in power, mileage is fine, starts up fine.

Any idea on what to check next? I don't really have the money to take it in.

Thanks for any input :)
 

·
Registered
Joined
·
993 Posts
If you dnt have the funds, and you do have the tools, might want to pull the engine and clean everything out. Then you could find the problem areas.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
I could barrow a lift to get it out but I wont have anything to drive in the mean time. Our other car is in the shop for accident damage.. bad luck this month.

Going to smoke it out for now, see if I missed any leaks.
 

·
Registered
Joined
·
993 Posts
Good luck, its tough to work on these cars with such a tight engine bay.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·
Tried the gas cap with no luck, and the smoke test didn't show any leaks.

The idle dropped to ~900 after I added fuel treatment but its still not quite normal. :shrug:

I should be able to bring it to the shop in a couple days.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
Nope, I got it new back in 09.

I'm trying to find a good shop as the dealer tries to replace everything lol

Also getting terrible mileage when it is below half a tank now.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
Well good news.

Today the light cleared, idle went back to 650 and I'm getting 30 mpg again.:wiggle:

I haven't touched anything in a few days so not too sure how it fixed itself or what even happened in the first place. weeeird
 

·
Registered
Joined
·
993 Posts
Must of been something the computer needed to figure out on its own.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top