Nissan Versa Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
So about 2 weeks ago with no prior issues my 09 Versa started fine leaving my house as I went to the corner store just down the street. When leaving the store I tried to crank as normal and everything went dead after one click as if I had a dead battery or some kind of short out.

I pop the hood and checked battery connections for corrosion/loose connection and they were fine. When I was touching the wires I heard the power come back as I'd left the key in the ignition and it started beeping. Tried to start again and power went dark again. I did this one more time and it cranked fine and I didn't have an issue again for a few days. It would happen randomly but would always start after one or two tries.

Now, today the car has power but will never turn over and fire up. I'm pretty sure I can hear the fuel pump prime with the key on engine off, I checked all fuses relating to fuel pump, I did read in another thread that THIS PART can potentially cause a no spark scenario if one of the fuses is burned but it's hard to tell.

Does that part sound like it could cause those issues? Shorting out then cause no spark? The car no longer loses power at all just never fires up.
 

·
Premium Member
Joined
·
3,272 Posts
I would clean the connections and make sure they are seated properly. In my experience though a single click but no cranking means starter. Next time it happens try tapping on the starter and see if it starts. If this is manual you can also try push starting the vehicle.
 
1 - 2 of 2 Posts
Top