Nissan Versa Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter · #1 ·
About to hit 260k mile. not sure if the oil pump is going or if its a bad seal. I noticed oil getting in the sparkplug tubes when i changed em last. gonna have to break down and take it apart and do some gasket replacements.
 

·
Registered
Joined
·
2,359 Posts
it could be the valve cover gasket

well...
seals don't last 4ever

260,000 miles is more miles than the distance from here to the moon
estimated (238,857 miles)
 

·
Premium Member
Joined
·
3,270 Posts
Oil light is low pressure light. That is what it is in all cars. That coming on is not good and the head is not being properly lubed if its on. 260k is alot of miles but I would still not want engine failure at that mileage.
 

·
Registered
Joined
·
2,359 Posts
ohh I see. I thought the oil light only comes on when a low oil level was detected but

when the oil is low....
The oil pressure is low...

So...

can you have low oil pressure even when the oil is full?
if that's the case, could the oil pump be broken?
 

·
Registered
Joined
·
221 Posts
Discussion Starter · #8 ·
talked to nissan. My service rep said that they rarely replace oil pumps on older mileage nissans but they do put sending units in. So i got a new sending unti and valve cover gasket for 20 bucks. Ill go from there. If that dosent work then ill drop the oil pan and replace the oil pump
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top